Ferrari Forums banner
1 - 3 of 3 Posts
G

·
Discussion Starter · #1 ·
My 83 308 GTSi qv sat for a fe

My 83 308 GTSi qv sat for a few months. Normally it starts right up even after sitting for months at a time. This time - it just cranks and cranks and never starts up. I checked all fuses and they're all ok. I pulled the fuel line off where it enters the fuel distributor and cranked the engine expecting fuel to come out. Nothing came out. Shouldn't fuel have come out?

This leads me to believe that it's the fuel pump... Is my assumption accurate? I switched out the fuel pump relay with another relay (same part#) from a different circuit. Still nothing...

If I replace the fuel pump, should I replace the accumulator at the the same time? The acculuator has a vent that appears to have been leaking fuel. (I have smelled fuel in the garage and seen marks on the floor as well, directly under it)

Thanks to anyone who can offer any thoughts...
 
G

·
Discussion Starter · #2 ·
On my carbed 308GTB you can he

On my carbed 308GTB you can hear the pump when running....some of them are quieter. It does sound as if it's frozen, if you don't have fuel pressure.

The leak is a second problem. Can anyone comment on this leaking vent issue? I think you are wise to fix that at the same time!

Sorry I couldn't be of more help on an injected model.

Welcome to the site, as well......
 
G

·
Discussion Starter · #3 ·
First you will need to verify

First you will need to verify that you are getting power to the fuel pump. What is the voltage reading at the pump?
 
1 - 3 of 3 Posts
Top